The Hacker Voice Community Forums: fn keys not working after upgrading backtrack to 5 R2 - The Hacker Voice Community Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

fn keys not working after upgrading backtrack to 5 R2 no external vga display Rate Topic: -----

#1 User is offline   Signius 

  • signius
  • PipPip
  • Group: Admin
  • Posts: 13
  • Joined: 01-December 08
  • Gender:Male
  • Operating System:Linux, Windows, Solaris, OpenBSD & FreeBSD
  • Ninja or Pirate?:Pirate

Posted 05 May 2012 - 02:22 PM

I recently upgraded my Lenovo X100e from Backtrack 5r1 to 5r2
After upgrading i was unable to get any external vga display which is pretty vital on my laptop as the screen is smashed
.

Trying "xrandr --output VGA --auto" gives "Can't open display"

After some head scratching and googling the culrpit pointes towards grub & acpi (yeah acpi is still a fucking PITA in Linux even in 2012)

So after having to blindly type some commands into the laptop with no screen output of any kind either external VGA or SSH as Backtrack kindly wiped all my previous settings


Backtrack 5 R1 - Code Name Revolution 32bitbt tty1 (yeah i know its still displaying R1, fuck knows, but it is running R2 honestly)
bt login: root
Password: yourrootpassword

When using a ssh server for the first time on Backtrack you will need to generate keys:
root@bt:~# sshd-generate # Specific to the SSH service - needed to generate SSH key

root@bt:~# /etc/init.d/ssh start
Starting OpenBSD Secure Shell server: sshd.

To enable a service at boot time, you can use the update-rc.d command, for example, having SSH start at boot time:
root@bt:~# update-rc.d -f ssh defaults
Adding system startup for /etc/init.d/ssh ...
/etc/rc0.d/K20ssh -> ../init.d/ssh
/etc/rc1.d/K20ssh -> ../init.d/ssh
/etc/rc6.d/K20ssh -> ../init.d/ssh
/etc/rc2.d/S20ssh -> ../init.d/ssh
/etc/rc3.d/S20ssh -> ../init.d/ssh
/etc/rc4.d/S20ssh -> ../init.d/ssh
/etc/rc5.d/S20ssh -> ../init.d/ssh

I had to do all of the above with no display of any sort, so having to assume all the commands completed correctly then i rebooted the box with
reboot

When the box came back up again after the reboot i tried to ssh in from another box and success :)

Once i had got into the box via ssh i then edited Grub

vi /etc/default/grub
change the line GRUB_CMDLINE_LINUX""
to
GRUB_CMDLINE_LINUX=”acpi_backlight=vendor”
then the usual esc :wq to save and exit vi
then update grub with

update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.6
Found initrd image: /boot/initrd.img-3.2.6
Found linux image: /boot/vmlinuz-2.6.39.4
Found initrd image: /boot/initrd.img-2.6.39.4
Found memtest86+ image: /boot/memtest86+.bin
done

then do a reboot with
reboot

Now when i use the function keys in my case fn + f7 my external display now works. WOO HOO :)
0

#2 User is offline   spanglesontoast 

  • Dedicated Member
  • PipPipPipPipPipPip
  • Group: Pink Hat
  • Posts: 506
  • Joined: 12-March 06
  • Gender:Male
  • Location:West Sussex
  • Interests:Linux, Mysql and PHP anything related to content management :)
  • Operating System:Sabayon. Gentoo and ubuntu
  • Ninja or Pirate?:Ninja

Posted 07 May 2012 - 07:36 PM

handy :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users